Market Offers

Incident Report for Website status

Update

We are continuing to work on a fix for this issue.
Posted Dec 12, 2024 - 13:33 EAT

Update

We are continuing to work on a fix for this issue.
Posted Dec 12, 2024 - 13:29 EAT

Identified

Currently we have no offer opening. Preparing for you some great takeaways. Keep in touch via our website : https://isa9.xyz.
Posted Dec 12, 2024 - 13:29 EAT
This incident affects: Offer Page.