Call Outage

Incident Report for Website status

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2024 - 11:14 EAT

Monitoring

We are working to enable calls. Meanwhile calls remain affected while other means of communication are operational.
Posted Dec 12, 2024 - 11:14 EAT
This incident affects: Phone Number.